Car will not start after wash - LegacyGT.org
LegacyGT.org     subaru gift, subaru calendar

 

Go Back   LegacyGT.org > Legacy Technical > Engine, Power, & Performance

Reply
 
Thread Tools Display Modes
Old 02-12-2015, 10:28 PM   #1
Prox
Junior Member
 
Join Date: Feb 2015
Posts: 2
Default Car will not start after wash

Hello there!

just wondering if anyone has any advice on what I can do about my '97 Legacy GT Jap Import (NewZealand).
Gave it a wash for the first time since owning it, using a water blaster, nothing under the engine bay or anything like that, just exterior.

In the past has started up everytime with no hassle. However, this time when I turn the key, these lights come up:

and no turn over or anything. I have an aftermarket immobiliser/alarm but I'm using it just the way I normally would.

I'm hoping that overnight, whatever got wet has dried and it will start.

I have minimal mechanic experience and don't even understand the fusebox.....


thanks a lot for reading, any advice would be rad!
Prox is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 06:10 PM.



Subaru and Legacy are trademarks of Fuji Heavy Industries and are used here for identification purposes o­nly. The comments and content are property of their posters.

Powered by vBulletin®
Copyright ©2000 - 2010, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect