Stuck at only 5 PSI - LegacyGT.org
LegacyGT.org     subaru gift, subaru calendar

 

Go Back   LegacyGT.org > Legacy Technical > Engine, Power, & Performance

Reply
 
Thread Tools Display Modes
Old 10-18-2018, 11:02 PM   #1
atambunan
Junior Member
 
Join Date: Oct 2018
Posts: 1
Unhappy Stuck at only 5 PSI

My LGT only hits maximum 5 psi of boost. It feels kind of sluggish. I replaced the turbo because I was told my turbo was bad, I know the new turbo is good because it was running in my friends car. It still does the same thing with the old turbo. Doesn't build more than 5 psi. It doesn't have the restrictor pill in if that makes a difference. It is stock with no mods, previous owner just took the catback off so its running out the downpipe. Sometimes the car does crank a little bit longer than usual to start. Have the P1491 code for the PCV. Thinking it could be my BCS, but I'm probably wrong. or could it also be my BPV, previous owner cut the recirculating hose and plugged it. Not sure if it could be bad. MAF? I've heard multiple things. Thanks in advance

Last edited by atambunan; 10-18-2018 at 11:07 PM.
atambunan is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 02:49 PM.



Subaru and Legacy are trademarks of Fuji Heavy Industries and are used here for identification purposes o­nly. The comments and content are property of their posters.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Powered by vBulletin®
Copyright ©2000 - 2010, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect