Weird noise coming from the motor - LegacyGT.org
LegacyGT.org     subaru gift, subaru calendar

 

Go Back   LegacyGT.org > Legacy Technical > Engine, Power, & Performance

Reply
 
Thread Tools Display Modes
Old 08-26-2018, 09:03 AM   #1
Zachzark
Junior Member
 
Join Date: Aug 2018
Posts: 2
Default

Hi, I have had my Subaru Legacy GT (2006) for two months now. It's my first turbo vehicle and have recently been hearing weird noises, I believe from the turbo. It happens when the car is warmed up and around 30-40 mph from a stop. Not sure if anyone has had this problem before but I was hoping for some help I know it's hard to te what it is from a video but I am stuck with figuring it out. Thank you in advance. If the video posts, it is noticeable at 0:50 .

Last edited by Zachzark; 08-26-2018 at 09:55 AM. Reason: Wrong time
Zachzark is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-26-2018, 09:56 AM   #2
Zachzark
Junior Member
 
Join Date: Aug 2018
Posts: 2
Default

https://youtu.be/SA5p_1g8qBM here is the link to the video.
Zachzark is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 12:17 AM.



Subaru and Legacy are trademarks of Fuji Heavy Industries and are used here for identification purposes o­nly. The comments and content are property of their posters.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Powered by vBulletin®
Copyright ©2000 - 2010, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect